Quicken Will Not Work with Lion? Time to Switch to iBank

by

[UPDATE on 7/20/2011] – In addition to the post below, please also read the Updated Post with VERY important info!

With Mac OSX Lion coming out any day now, you should be aware of which apps might not pass the compatibility check with Version 10.7. A growing list can be found here of both what will work, as well as those that will not. Of note in the latter category would be Quicken for Mac.

In a recent blog entry, Intuit clearly states that they will not support Quicken for Mac in Lion, and that users should consider migrating to Quicken Essentials to Mac if they would like continued support for their financial software needs. Be advised – the article clearly states that you would need to do the migrating BEFORE you upgrade to Lion, as even the data itself from Quicken for Mac will not open in the newest iteration of the Mac OS.

Rather than dealing with the hassle of juggling software that clearly has no desire to offer a clean upgrade path, I propose an alternative – switch to iBank from IGG Software. They are a native Mac application and have the smooth interface, drag and drop simplicity, and a support structure that Mac owners have come to expect from companies who get it.

Check out this earlier post for a breakdown of iBank.

6 Responses to "Quicken Will Not Work with Lion? Time to Switch to iBank"
  1. Yeah..we just had some Lion installers here at our Editing house. They say some apps are not working..and never will because Apple did not do any backward compatibility..even on software that was developed in the past 2 years. WHICH of course…we still use because upgrading Adobe and all these hundreds of apps and tools…every year is not cost-effective.

    It’s a BIG “NO CAN DO” on Lion until they offer a Rosetta installed version. I don’t care about the OS being a big “Bloatey” I want my apps to work.

    • I hear you about old apps not being supported…but here’s the philosophy I subscribe to with upgrades: if what you have now does what you need it to do, why bother changing? It’s impossible – and sometimes downright naive – to always go for the “latest and greatest.” one should never upgrade just to do it…always check to see if your necessary software can make the transition.

      I don’t blame Apple for dropping Rosetta. The apps that require it should have been enhanced to at least Universal Binary by now. PowerPC machines are nearly 6 years old!

Leave a Reply to Sassy Lou Cancel reply

PageLines